Hero Two
Creating Logos with

Vector Graphics

In this chapter

You’ve already learned that Paint Shop Pro is a capable vector graphics
program, as well as a paint and photo editor. This sets it apart from most
consumer computer graphics software on the market today and makes it
possible for users to create high-quality, scalable computer illustrations that
can be used in a variety of ways. In this chapter we’ll cover the following topics:

% Combining vector shapes with text by creating a vector logo
% Using vectors to create and print business cards

% Printing multiple images using the Print Layout utility and templates

*

Exporting vector graphics as clip art to use with other applications

Vector graphics were the first type of computer graphics to be widely used by
graphic artists and are still the tool of choice for most. Most of the
nonphotographic images you see in magazines, newspapers, and books began
life as vector illustrations. Although Paint Shop Pro isn’t quite as powerful as
dedicated vector drawing programs such as Adobe Illustrator and CorelDRAW,
you can still create professional vector illustrations using it.
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Creating a vector logo
1. Begin by opening a new 700x400 image with a

white raster background. Set  the
foreground/stroke to null and make the back-
ground/fill a solid color of your choice. This will
be the color for the logo but, because of the
nature of vector graphics, you get to change
your mind about this at any point along the way.

Although transparency is a useful tool,
the checkerboard can be distracting.
It’s often a good idea to start with a
white background to give a cleaner
view of your work. You can turn off or
delete the background at any time
during the project.

. Activate the Preset Shape tool, uncheck Retain

style so your color of choice will be applied, and
check Create as vector and Anti-alias. As you
have a null stroke, the Line options don’t matter.

. Select the Ellipse shape from the Shape list and

drag out an ellipse approximately 300x150 pix-
els. An easy way to do this is to keep an eye on
the cursor coordinates at the bottom-right of
the task bar. Start your drag at about x:200,
y:100, and drag downward and to the right to
x:500, y:250. Absolute accuracy isn’t necessary,
so don’t be too fiddly about this.

. After you've laid down the ellipse, switch to the

Object Selection tool and click the Center on
canvas button in the Position on canvas area of
the Tool Options palette.

This may be a good time to make sure you've
checked the All tools box in the Materials palette.
This ensures that your color choice is maintained,
whatever tool you use.
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Creating Logos with Vector Graphics

5. Deselect the ellipse by clicking an empty part of
the canvas with the Object Selection tool.

6. Activate the Text tool. Because different fonts
can require different settings to make this
project work, start off using the same font and
settings we use and later, once you get the

The term “leading” (pronounced
ledding) refers to metal lead and comes

method down, experiment with more personal- from. the Rractice of using Iegd strips of
ized choices to exercise your own creativity. In varying widths to separate lines of text
the Create as field, choose Vector; set Size to in the days of metal type.

32, Stroke width to 0, Font to Arial, and Font
Style to bold; and center the alignment. Leave
Kerning at 0 and set Leading to —350.
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7. Place the cursor over the top center of the
ellipse (approximately x:350, y:125). The cursor
changes from the regular text cursor to the
“rocking A” text on a path cursor. Click the
mouse when you’re there to bring up the Text
Entry dialog box.

8. Type in a few words made up of 10 to 12
characters. The text is centered on the top and
follows the path of the ellipse, but it’s sunk
about halfway down into it because of the
leading value you used. If you chose a different
font, you may have to adjust the leading value
and/or the font size to get the same effect. By
highlighting the text in the Text Entry dialog
box, you can adjust these settings if needed and

. . Tenl Erbry L=
the canvas will update to let you know if you CIFrE
have it right. Click Apply in the Text Entry I'I'I'I:I-I:EI'.
dialog box when you’re satisfied.
When you apply the text, it should be selected. If it
isn’t, activate the Object Selection tool and select it.
i merarsterie .
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Now you want to make the text a vector path. This
will change it to nodes and segments independent of
the font file and allow you to combine it with other
contours in a single vector object.

9. Go to Objects > Convert Text to Curves > As
Single Shape to combine all the characters into
one vector object.

10.Now you want to combine your text with the
ellipse to create a single object. Ensure the text
is still selected and activate the Pen tool in Edit
mode. You should now see the text with its
nodes.

11.Select all the nodes in the text, either by drag-
selecting or choosing Edit > Select All from the
right-click context menu. Right-click again and
choose Edit > Cut. This copies the nodes to the
clipboard and removes them from the canvas.

12.Although there’s nothing visible, the object still — [{irer . Vectes | Fim
exists in the Layer palette so, for the sake of |@ @ E @ % @ » bl
neatness, you may want to delete it by expand- i‘ et = R T
ing the Vector 1 layer, right-clicking the layer - = :
containing the text, and selecting Clear. Oy & Cud it
B babpned By oo chikss
Now you’ll combine the copied text with the ellipse.
o Oes I Dd=e
13.Click the ellipse using the Object Selection tool ]

and then activate the Pen tool, again in Edit
mode. Right-click the ellipse and choose Edit >
Paste. Your text reappears, but this time as part
of the same object as the ellipse.

Unfortunately, when you paste nodes into an object
in Paint Shop Pro, it offsets them 10 pixels to the right
and below the original position, so you have to nudge
them back to where they should be. This is easily
accomplished by using the arrow keys while holding
down the CTrL key. This combination nudges the
selected nodes 10 pixels in the direction of the arrow
key used.

Nodes Pasted out of Position
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Creating Logos with Vector Graphics

14.Press CtrL+up arrow key and Crri+left arrow
key to relocate the text to its original position.
(Pressing the arrow keys without holding down
the CtrL key will nudge the selected node by 1
pixel at a time.)

Though that’s all fine and dandy, it doesn’t appear to
be any different from what you had a couple of steps
ago. You may recall from Chapter Five that when
contours going in opposite directions overlap, the
overlapping fill area is canceled out. As you can see,
the overlapping area in your object isn’t canceled out,
so the ellipse contour must be going in the same
direction as all the text contours.

15.To remedy this, simply select any node in the
ellipse contour, right-click, and choose Edit >
Reverse Contour. Deselect the ellipse and now
your overlapping text area is canceled out.

Adding extra detail

Perhaps you now want to add some more text to your
logo, such as a company name and address.

1. Go back to the Text tool and change the font
size to 12 and Leading back to 0. In the
Materials palette, change the fill color to some-
thing that will contrast against the ellipse color.
While holding down the ALT key to prevent text
on a path, click somewhere just above and left
of center and enter two or three lines of text.
Go to the Object Selection tool and move the
text to a better position if necessary.

2. With the text selected, right-click and choose
Convert Text to Curves > As Single Shape.

3. With the Pen tool selected, right-click and
choose Edit > Select All.

4. Now right-click the text and choose Edit > Cut.

-
A D
5. Use the Object Selection tool to select the
ellipse.
APRESS
6. With the Pen tool, right-click and choose Edit > 2560 Minth Strast
Paste. Berkeley, CA,

7. Use Ctrit+up arrow key and Crrutleft arrow key
to nudge it back into position.
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You have some empty space over on the lower-right
side that you can add a graphic to.

8. Activate the Preset Shape tool and select a
suitable single object shape. These are all black
in Paint Shop Pro—the multicolor shapes are
made up of object groups and aren’t suitable
for this procedure.

9. Choose a suitable shape and lay it down where
you want it. You'll have to start the drag outside
the ellipse, as the Preset Shape tool won’t start
an object inside another. If you can’t locate it
just where you want it, switch to the Object
Selection tool and move it as needed.

Now you need to go through the cut, copy, and paste
procedure again. It may or may not be necessary to
reverse the contour depending on the shape you
used. When you paste the nodes into the ellipse, if it’s
already cut out, don’t reverse the contour. As a
reminder, here’s the process again:

* Select the shape with the Object Selection tool.

% Activate the Pen tool. Right-click the shape and
choose Edit > Select All.

* Right-click again and choose Edit > Cut.
#* Select the ellipse with the Object Selection tool.

% Activate the Pen tool, right-click, and choose
Edit > Paste.

* Nudge the shape back with the Ctri+up and left
arrow keys.

# Reverse the contour if necessary.
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2560 Minth Street
Berkeley, CA.

2560 Minth Strest

Berkeley, CA.




Creating Logos with Vector Graphics

10.Finally, you can add some additional text, such
as a name and a web page URL.

With a little imagination, but not necessarily any great
drawing ability, you can use these methods combined x ] :
with the Pen tool to come up with all sorts of 2260 Minth Street
S S Barkaley, CA,
imaginative vector graphics:

Ron Lacey
hittp: Ihww. apress. com

Ontario

Printing with templates

So, after you’'ve made all these interesting vector
shapes, you’re probably wondering what to do with
them. Vector graphics are great for print projects.
They can be scaled without loss of quality, so a single
graphic can be put to a variety of uses in print. If
you’ve ever used clip art in a newsletter or poster,
chances are it was vector.

Let’s take the vector logo, use it as a business card,
and print it right here in Paint Shop Pro.
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1. Select the logo and added text with the Object
Selection tool, right-click, and select Group.

2. Right-click and drag (to maintain the aspect
ratio) one of the corner handles, so the object
completely fills up the workspace. Once it’s
resized, click the Center on canvas button in the
Position on canvas area of the Object Selection
tool options.

We started with a 700x400 image for a reason: Avery
and other companies make perforated business card
stock at 2 x 3 1/2 inches, which is the size of our
graphic at 200 ppi. This stock includes Avery product
numbers 8371, 8372, 8374, 8379, and 8376, among
other specialty stock, and Paint Shop Pro has print
templates for many Avery products, including the
business card stock.

3. Go to File > Print Layout to open the Print
Layout utility. There’s a blank white representa-
tion of your print paper in the work area and
any open images on the left sidebar. If you
want, you can drag any open image from the
sidebar to the blank paper and drop it in posi-
tion. You can also drag and drop any number of
the same image.

Any image you drag over will be selected, as indicated
by the bounding box, and dragging any corner in or
out will resize the image while maintaining the aspect
ratio. Pressing the DELETE key or right-clicking within a
bounding box and choosing Remove from the
context menu removes a selected image. The context
menu also gives you zoom options and allows you to
rotate, remove, and position the selected image on
the page.

4. Because your logo is already the correct size,
you can call up the print layout template for the
Avery business card stock. Go to File > Open
Template to see the Templates palette.

5. Highlight Avery in the category field and locate
template 8374 in the preview pane. Double-
click the preview thumb to load the template
onto the workspace.
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Creating Logos with Vector Graphics

6. You can now drag your image from the sidebar
into a cell on the template. In our case,
the image will fit the cell exactly but, if the
image were larger than the cell, only the
portion within the cell would appear or be
printed. In cases where the image is larger or
smaller than a given cell, you can use the Cell
Placement options from the context menu
to locate it within the cell. The Cell Placement
menu replaces the Image Placement menu
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7. You can drag the image from the sidebar to
each individual cell, or you can fill all cells in
one fell swoop by right-clicking in a cell and
choosing Fill Template with Image.

8. Once done, you can check your printer options
with File > Print Setup and then use File > Print
to commit your creation to paper.

If you don’t want to print right away or you think you
may need to make more copies at some time in the
future, you can save the template compete with
images.

9. Choose File > Save Template to bring up the
Save dialog box, where you’re prompted to give
the template a name. To save the images with
the template, simply check the Save with
images box.
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10.When you want to reload the template, you'll
find it listed in the Select a category area of
the Templates dialog box, filed under User
Defined. Templates with cells containing images
have those cells highlighted in cyan in
the Templates dialog box. You can also remove
templates from this dialog box by clicking them
and pressing DELETE.
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Creating Logos with Vector Graphics

Exporting vectors as clip art

If you've ever produced a newsletter, poster, or
birthday card using desktop publishing software such
as MS Publisher, or if you’ve ever composed a letter
in your word processor using clip art, it’s likely that
the graphics you imported were vector clip art. Most
clip art collections sold are made of vector graphics,
usually in Windows Metafile Format (.wnf) or
Extended Metafile Format (. enf ). The reason for this
is the scalability of vector graphics. Because this art
is often used for enhancing printed documents, the
creators have no idea how big an image the user will
need: a tiny postage stamp-sized image to use in a
letterhead or a large graphic for a banner or poster?

Because neither the . enf nor the . wnf file format
supports gradients, patterns, or textures, it’s best to
use solid color objects for exporting. Anything else
can yield unexpected results.

You can export your vector art to .wif or .enf
format in Paint Shop Pro from the Save or Save As
dialog box. If your publishing software supports . enf ,
this is the preferred format.

1. Crop your image tight to the drawing and
delete any raster layer, including the back-
ground layer if you have one.

2. Go to File > Save As and choose the appropri-
ate format (either . enf or .wnf).

3. Click the Options button in the Save As dialog
box and select Save bitmap and vector data
(after you set this option once, the save options
will default to it whenever you save to this for-
mat again).

4. Choose a file name and a location to save the
file to.

Now you can use your favorite desktop publisher to
create personalized newsletters and other print
projects.
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