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What we’ll cover in this chapter:
Text in Fireworks MX

Using the Text tool and the Property inspector
Character and lines spacing
Setting direction and orientation
Setting alignment
Smoothing text edges
Setting paragraph spacing

Converting text to a path
Cutting text out of an image
Placing text on a circular path
Pasting an image inside text on a path

Text effects
Making great 3D text
Metal text
Filling text with an image
Gold text with custom bevel
Creating a reflection
Producing clear small type
Adding copyright and trademark symbols
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In this chapter, we’ll take a quick look at how text is handled in Fireworks MX because it has totally changed
since previous versions. We will then quickly move into using the Text tool to generate spectacular text effects.
Using text effects and specially treated text is a popular element to enhance a web page. Whether the text is a
title, a subhead, or even a logo, it can be a very important part of your message. 

I have experimented with different text effects, and the most realistic by far have been those made using
Photoshop. But Photoshop is primarily a bitmap image-editing program, so how can those techniques be
translated into a Fireworks text effect? As you work through the various exercises in this chapter, you will begin
to see the true power and flexibility of Fireworks. You’ll be truly amazed at some of the things you can do that
you may have thought you could do only with bitmap tools. 

You’ll learn how and why to convert text to a path, as well as how to attach text to both the top and bottom
of a path. Another problem area with text is the use of small fonts; you’ll learn the tricks to using a small font
that is readable and clear on the monitor screen. Adding a copyright or trademark symbol is thrown in so that
you know how to do it in Fireworks. You will also learn the quickest and easiest way to produce a dotted or
dashed line. Then the real fun begins – text that stands, great 3D text with rust, special bevels, and glows. Next
you’ll move on to producing text filled with an image, text cut out of an image, and some realistic gold text.
For a sneak preview of the text that you’ll make in this chapter, refer to the Color Studio section of this book.

The vector capabilities of Fireworks are one of its huge benefits. Not only can you make the majority of your
images (or all of them, if you’d like) using vectors, which are fully scalable, but they also remain fully editable.
You’ll be amazed at the number of effects that are normally used only on bitmap images that can be used for
vector images. You’ll learn some tips and tricks to manipulate your text into bitmap appearance while retaining
all the advantages of still being a vector. You can easily evaluate an image when you keep the PNG source file
in a safe place. With the original file, you can access the settings used for all the effects, strokes, and fills applied.
But if you’ve converted the image to a bitmap at any point, the editability of that portion will be lost.

Using the Text tool and the Property inspector
The way you work with text in Fireworks has totally changed. In previous versions, you needed to select the
Type tool and then click on the canvas, whereupon the Text Editor would open. The Text Editor contained the
various choices you had for the font style and alignment.

In Fireworks MX, text is now handled right in your open document, and the text options are now found on the
Property inspector instead of the Text Editor. All the normal options are now in the Property Inspector: the font,
size, color, leading, kerning, and alignment. A few new options for text are provided. To the right of the
alignment buttons you’ll see a new icon, which has some options for horizontal and vertical orientations of the
text. Also there are several options for paragraph text, such as Space Preceding Paragraph, Space After
Paragraph, and Paragraph Indent.
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Character and lines spacing

Let’s find out what these options do.

Horizontal scale is represented with a wide capital A over a
horizontal arrow. This enables you to change width of fonts
to make the individual letters either narrower or wider than
the standard 100 percent size.

Baseline shift is represented by two capital A’s and an
upward arrow. This lets you set text that falls above of below
the lower border of the text box.

Leading displayed as a vertical arrow between two lines,
appropriately this lets you adjust the amount of space
between lines of text.

Kerning represented by an A/V and arrows, this feature lets
you change spacing between characters.

Setting direction and orientation 

Placing your text orientation horizontal and vertical is not very
difficult when you use the text orientation button, shown in figure to
the right:

Setting alignment

Text is aligned within the text box with the help of the alignment buttons in the Property inspector. Text can be
aligned left, right, centered, justified, or stretched. The basic alignments are the same as in most word
processing programs, with the addition of justified and stretched.

Justified makes the space between the letters change. Stretched makes the text stretch to fill the box. Actually
both of these make the text stretch to fit the text box, so adjusting the size of the text box will adjust the size
of the text.

Smoothing text edges

To smooth out the text edge, you anti-alias it. Anti-aliasing controls the appearance of edges by mixing pixels
along the border of an image, thus creating a crisp line.

In the Property inspector, choose an option from the Anti-Aliasing Level menu: Crisp, Strong, Smooth, or No
Anti-Alias. Practice with all the options until you find the level that gives your text good results.
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Setting paragraph spacing 

Another new feature to Fireworks MX is the ability to format paragraphs using the Property inspector. These
paragraph spacing controls let you add space after a paragraph, control the indent, and add space before and
after paragraphs.

You can also access the majority of text options through the Text menu, including the option to open the Text
Editor. In practice, though, as it’s so handy to have all the text controls right in the Property inspector, you
usually don’t need to use the Text menu. However, a few special text-handling techniques, such as attaching text
to a path or reversing the direction of the text on the path, are found in the Text menu rather than the Property
inspector along with a Spell Checker. 

Adding text is now as easy as clicking on the canvas and
typing. To change the text, highlight it with the Text tool or
select it with the Pointer tool. 

Converting text to a path
Why would you want to convert text to a path, and what is
the purpose of a path? First, text is a vector object, and you
can alter the entire word, sentence, and so forth, or each
individual letter’s properties but you can’t make any physical
shape changes to the individual letters themselves. If you have
a great script font but would like to alter the ascender a bit,
you’d need to convert the text to a path (Text > Convert to
Paths) before you could edit it. Once the text is converted to
a path, you will see the individual nodes that make up the
path of each letter. Fireworks keeps the group of nodes for
each letter as a group after the conversion to a path. To see
the actual nodes, you’ll have to select the text and choose
Modify > Ungroup.

Cutting text out of an image

You can convert text to a path, ungroup it, and then use the Modify > Combine Paths > Union command to
make it into one vector shape. This is very useful when you want to cut text from another image or object.
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Photoshop Tip: The main difference in
editing text in Photoshop is that
Photoshop has its properties in the
Context bar and Fireworks has
everything in the Property inspector.
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After text is converted into a path, it can be used just like a cookie cutter. By placing the converted text on top
of another path object, you can punch it out, leaving a see-through hole. You can produce some pretty neat
effects with this process. In this exercise, you will punch a hole through an image and see the image that has
been placed below it.

1. Open a new a new image and use the following settings:

Width: 300 pixels
Height: 300 pixels 
Canvas Color: Whatever color you like

2. Select the Rectangle tool (U) from the Tools panel and draw a rectangle to fill the canvas. Place your
cursor outside the canvas area and click and drag to cover the entire area.

3. In the Property inspector, select Pattern from the Fill
category list,then select Other from the Fill Type list. Go
to the folder where you saved the files you downloaded
from www.friendsofed.com and select shellback.
png. The canvas will be filled with the shell background.

4. Clone (Edit > Clone or CTRL/CMD+SHIFT+D) the filled
rectangle, add a new layer (Edit > Insert > Layer), and
move the clone to Layer 2 by clicking and dragging the
object.

5. Select the cloned copy on Layer 2. Choose a Pattern fill
again, and then select Other and browse to the
sand.png image in the Chapter 8 images folder.

6. Type the text you want to use as a cookie cutter. The
text and settings used in this example are as follows:

Text: Shell Seekers 
Font: Tarzan
Point Size: 62
Color: Black
Edge: Smooth Anti-Alias

If you have a pattern which tiles, select
the circle handle and drag up to the top-
right corner to fill with just one image
instead of four.
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(The Tarzan font is available from www.buyfonts.com and costs $2.00, however you can use an alternative
one if you wish.) 

7. I wanted the text to cover more surfaces so I
distorted the text. To do this, choose Modify >
Transform > Free Transform. Pull down on the
bottom middle point.

8. To make the text into a punch, select:

Text > Convert To Paths (CTRL/CMD+SHIFT+P)
SHIFT+select each letter with the
Subselection tool (A, 1)
Once you have selected each letter, go to
Modify > Ungroup
Be careful not to select the rectangle and go
to Modify > Combine Paths > Join
(CTRL/CMD+J)

9. SHIFT+select the text and the rectangle, and from the menu bar, choose Modify > Combine Paths > Punch. 
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Sometimes it’s difficult to select both objects
if they are similar in size. Two other ways exist
to select them both or to select multiple
items. Select the object from the Layers panel
and SHIFT+click each object to select them, or
use the Pointer tool and click and drag a box
around the objects you want to select. You
won’t see the box except while you are
dragging it, but you will notice the handles
turn blue for all the objects you enclosed.
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10. The hole is punched through the sand object
and the shell object becomes visible through the
cutout. Click on the shell object and position it
below the cutout text until you like the colors
below the text.

11. Select the sand object by clicking on it. In the
Property inspector, from the Strokes category
list, choose the following:

Air Brush: Basic
Tip Size: 4
Color: 996666 (dark brown).

12. Click on the Add effects or choose a preset
(plus sign) button in the Property inspector to
access the Effects list and choose Shadow and
Glow > Drop Shadow with these settings:

Distance: 4
Opacity: 65% 
Softness: 3
Angle: 315
Color: Black 

In this example, it is difficult to see the
changes in real time on the canvas
because there are so many points on the
path. To see clearly, deselect by clicking
outside the image area. Then reselect
before applying or making changes to
the effects or strokes.

The plus sign in the Property inspector
accesses the Effects list if the Property
inspector is open all the way. If you don’t
have the Property inspector open with
the full view, an Add Effect or Edit Effects
button will be visible.
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Placing text on a circular path

In this section, text will be put on the top and the bottom of a circle independently. To do this, the path has to
be cut in half, forming two arcs, and then the direction of the bottom type has to be reversed.

1. For the object that you will place text around, open the birdlogo.png file from the Chapter 8 folder.

2. Select the Ellipse tool (U) and draw an ellipse around the
outside of the image, totally surrounding it. Use a fill of
None and a 1-pixel black stroke.

3. Type the word Exotic on the top. I used the following
settings:

Font: 01-01-00 (downloaded from www.fontfreak.com).
Point Size: 55
Color: Black
Edge: Smooth Anti-Alias
Alignment: Center

4. Type the word Birds with the same settings and move it to the bottom. The position really doesn’t
matter.
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The alignment will make a difference to
the position of the text when you place it
on the circular path.
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5. Select the ellipse and select the Knife tool (Y). To
cut a straight line, press the SHIFT key as you slice
horizontally. You can slice anywhere you want – it
doesn’t have to be in the center. In the image to the
right, I moved the bottom arc down a bit so you
could see the cut, but it will be moved back into
position.

6. SHIFT+select the top text and the top ellipse, and
choose Text > Attach To Path (CTRL/CMD+SHIFT+Y).

7. Even though the text is attached to the path, you can
still change the font attributes without removing it
from the path. Select the text and change the Kerning
to 20%.

8. Repeat Step 6 for the word Birds. 

If you want to move the path you just
sliced, click in your document to deselect
the path. Next, select the path you’d like
to move, and click and drag it wherever
you’d like. Notice that you now have two
open paths instead of one closed path.

If your text automatically jumps to the
beginning of the text, then you need to
check your alignment, the text should be
aligned to the center.
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9. The text is now upside down so choose Text > Reverse
Direction.

10. Highlight the text with the Text tool to select it and in the
Property inspector change the Baseline Shift to –30.

11. Save the file as mybirdlogo.png but leave it open for the next tutorial.

Pasting an image inside text on a path

Yes, you have read this title correctly – you can paste an image inside text even after it’s been attached to a
path.. However, you can’t paste an image inside the text prior to putting it on a path. Put the text on the path
first, then drag it on top of the image you want within it and proceed as normal.

1. With your mybirdlogo.png file open go to File > Import and select the birdbackground.png file
from the friends of ED web site, (or you could use an
alternative file). 

2. Place it to cover the word Exotic. Where you place the
text depends on what portion of the image you want
to see in the text. I wanted the brighter colors on the
bottom so I lined the bottom up with the bottom edge
of the text.
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If you select the text on the path with
the Pointer tool the Property inspector
shows a stroke icon, but if you select the
text with the Text tool the Property
inspector changes and the Baseline Shift
(two A’s) is present.

To help you place the image you can
lower the opacity in the Property
inspector so you can see the text below
it. Once it’s in position be sure to return
the opacity to 100%.
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3. With the birdbackground.png selected, go to Edit > Cut (CTRL/CMD+X), then select the text, and
choose Edit > Paste Inside, (CTRL/CMD+SHIFT+V). 

4. From the Effects menu in the Property inspector choose Shadow and Glow > Drop Shadow and use the
default settings.

5. Repeat the steps 1 to 4 for the word Birds.
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6. To finish off your image, you could 
then change the canvas color to a
complementary color, by going to Modify >
Canvas Color, and then sampling a color
from the text. 

Here is the same effect, created using the Tarzan font, with a peach colored background. You can download
this image from the friends of ED web site. 

Text effects
In this next section of the chapter we’ll cover some of the best and most impressive text effects that you can
use in Fireworks MX. You can use these effects to add realism to your designs and really bring them to life. 

Making great 3D text

In this exercise, you will use a pattern file and several effects to produce text that appears to be rusted. You
can change the look by changing the pattern, the offset of the lower layer, and even the shadow. After you do
this exercise, experiment by adding different effects to the edges of the text or try different strokes for a variety
of results. To begin, follow these steps:

08 Fireworks MX: Zero to Hero
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1. Open a new canvas (File > New, CTRL/CMD+N) and give it a size of 400 pixels wide by 150 pixels high
with a tan canvas color, #FFCF9C.

2. Select the Text tool (T) and click on the canvas. Type the word Rusty. The font used for this particular
title is 96-point Whimsy TT with a color of black.

3. This first text object is going to be used as the edge of
the final text layer. To fill this bottom layer of text,
click on the fill box, then the Fill Options… button,
and select Pattern from the Fill category. In the Pattern
name area, scroll down and choose Other.... A dialog
box will open allowing you to locate the pattern to fill
with. In the Chapter 8 folder, there is a pattern named
rusty.png. Select this and click Open.

4. Staying in the Fill Options dialog box, go to the Texture
area. Choose Line-Horiz 1 at 100%. 

5. To bring back a bit of the color that was lost by
applying the texture, click on the plus sign in the
Property inspector to access the Effects list. Choose
Adjust Color > Hue/Saturation. Enter the following
values to obtain the result shown to the right:

Hue: –13
Saturation: –35
Lightness: –37

6. Now, choose Edit > Clone, CTRL/CMD+SHIFT+D. To
remove the existing effects from the cloned text, click
on the Hue/Saturation effect in the Property inspector
and then the minus symbol. 

7. Go back to the Fill Options, and change the Texture
amount to 0%. 

8. Using the keyboard arrow keys, move the cloned copy
up and to the left by 3 pixels by clicking on the up arrow
three times and the left arrow three times. 

The source file for rustytext.png is
included in the Chapter 8 folder. If you
open this file or any other that contains
a font you don’t have installed on your
computer, a dialog box will open giving
you the option to change the font or
maintain its appearance. If you choose
to maintain the appearance, the text
will be converted to a bitmap image.

The amount you nudge the top text
object will depend on the size of the text.
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9. In the Property inspector click on the stroke window, and
then on the Stroke Options button. Choose Charcoal for
the Stroke Category and Soft for the Stroke name. The Tip
size is 1. This image shows the top text object moved with
a stroke added.

10. Click on the plus sign in the Property inspector to
access the Effects list. Choose Adjust Color >
Brightness/Contrast, and enter a value of 20 in the
Contrast area. Click on OK.

11. Select both text objects by either SHIFT+selecting or choosing Select > Select All (CTRL/CMD+A).

12. Choose Modify > Group (CTRL/CMD+G).

13. The final touch is to add a shadow. Click on the plus sign in the Property inspector to access the Effects
list and choose Shadow And Glow > Drop Shadow. Change the settings to the following:

Distance: 10
Softness: 6
Opacity: 50%

Metal text

Here’s another popular effect, which creates very realistic looking metallic text

1. Open the brushedaluminum_45.jpg image from the download files for Chapter 8.
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You can select the top text object and
change the Layer Blend Mode to
Luminosity to achieve another nice
effect.
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2. We’ll use this as our background. It’s a little light so let's darken it up. Select the background image and
access the Effects menu, choose Adjust Color > Curves and use the settings shown here:

3. Type in some text using a large thick font. If the letters are
too close together, add a bit of kerning. This example used
Whimsy, size 72, and a Kerning value of 4.

4. In the Property inspector click on the Fill color box and
then click the Fill Options button. Choose Satin and click
the Edit button. Place your gradient color boxes as seen in
this figure. The colors used are medium gray and white.

Unlike the Brightness and Contrast options, Curves allows
you to darken or lighten individual pixels, rather than the
whole image.
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5. Once the gradient is added you can move the gradient handles to reposition the white highlights if you
like. 

6. From the Effects menu choose Bevel and Emboss > Outer Bevel and use these values:

Edge: Smooth
Width: 2
Contrast: 75%
Softness: 3
Angle: 315
Raised

7. Now choose Shadow and Glow > Drop Shadow from the
Effects menu, and just use the default values. It’s looking
pretty good. If you want a bit more refraction then the
next step will show you how to add this.

You could apply a Glass filter such as one that Alien Skins Eye
Candy 4000 uses, or you can do it yourself using the Pen tool and
the Path Scrubber tools, as we’re going to do now.

8. Zoom in to the first letter. Select the Pen tool (P) and in the Stroke category field set it to Air Brush >
Basic with a size of 2, an Edge of 100, and a color of white.

9. Draw a line down the outside of the first letter.
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You have to use the Air Brush because it’s a tool that works
with pressure sensitivity, which is required for the Path
Scrubber tools. You also need a minimum of 2 pixels, otherwise
,when we scrub, the entire line will disappear.
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10. Click and hold on the Freeform tools arrow in the Tools panel
to access the menu and select Path Scrubber Tool - Subtractive. 

11. Click once near the bottom edge of the line and to the right.

12. Deselect the line so you can see the result. Basically the line has
simply lightened and faded at the bottom end. 

13. To add a bit of brightness at the top of the line, select the Line
tool using white, a size of 2, Edge of 2, and Basic Air Brush.
Draw a tiny line at the top of the one you just drew.

14. For the highlight inside the M use the Line tool but only a size of
1 this time. This one doesn’t need to be faded.
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15. Use the same procedures (2-px line,
Subtractive tool, add a small highlight)
across the top of the E and T and the side
of A. Where you add the highlight is going
to depend on the font you use. Also, if
your font is curvy, use a Bezier curve to
follow the contours of the letter.

If you think you’d like to use this effect again
make a style of it. The style will save everything
except the lines you added for highlights.

16. Open the Assets panel group and click on
the Styles tab. Access the Styles Options
menu and choose New Style. Name your
style. I’ve unchecked all the text options,
otherwise the style would only work on the
same text at the same size.

17. Click OK to close the Styles dialog box.
Your new style will be added to the bottom
of your Styles panel.

Filling text with an image

This effect is deceptively simple, and very useful. I’ll show you a few tricks that
simulate what Photoshop can produce. Although we won't be able to change the
letters of our text, we will be able to edit the effects and place images inside. 

In this exercise, you will learn how to do the basic procedure of filling text with
an image.

1. Open the Seattle.jpg file from the Chapter 8 downloaded files.

2. With the Text tool (T), type the word SEATTLE in all caps. Use a solid or
thick font. I used the following settings:

Futura ExtraBold
110 points
Black
10% Range Kerning
Smooth Anti-Alias
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The techniques in
this section apply
not only to text
but also to any
vector shape.



Spectacular Text Effects 08

201

3. Place the text over an area you’d like to
see in the text, like this:

4. Select the image layer and cut
(CTRL/CMD+X).

5. Next, select the text object and paste inside (CTRL/CMD+SHIFT+V or Edit > Paste Inside). I added a drop
shadow to make it look even better. Notice where the arrow is pointing in the image below, this
cloverleaf symbol alerts you that an image is pasted inside this vector object.

Now that was easy enough. Let’s look at some variations of the same technique.

Filling only half of an image

Filling half of an image is very similar to what you just did in the previous exercise. Actually, you only need to
add in one step to get a result that looks completely different!

Start by opening the Seattle.jpg
file again. This time, instead of going
on to add the text right away, select
the Marquee tool (M) and make a
selection over the top half of the
image. Fill with white and deselect.

Now continue on with Step 2 of the previous exercise. You should end up with a result like the one shown
below:
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Filling a portion of an image with an uneven edge

When you see this technique, you will begin to appreciate the real possibilities of what you can achieve with
this effect. The Reshape Area tool is one that might seem intimidating, but it is very versatile and makes altering
a path extremely simple.

1. Open the Seattle.jpg file.

2. Select the Rectangle tool (U), draw a rectangle across the top portion of the image, and fill with a light
blue color.

3. With the Text tool (T), type the word SEATTLE in all caps. Use a solid or thick font and the same settings
as in the previous examples.

4. Place the text over an area
you’d like to see in the text.
The text object should be
above the Rectangle object
in the Layers panel.

5. Select the Reshape Area tool (O) and set the size to 40 and the stength to 80%

6. Select the rectangle and use the Reshape Area tool to alter the top path of the rectangle.

To use the tool, place your cursor outside the path and push up and around. Place the cursor behind some
of the text and push to make a different shape.
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A warning should open saying that this
tool works only on paths. This is a path,
but rectangles are grouped in Fireworks
and it isn’t being recognized as a path.
Just choose Modify > Ungroup (CTRL/
CMD+SHIFT+G).
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7. Turn the visibility off for the text and you will see the result of pushing on the path with the Reshape
Area tool.

8. When you are finished, group the rectangle and the bitmap together.

9. Select the image layer and cut (CTRL/CMD+X).

10. Then, select the text object and paste inside (CTRL/CMD+SHIFT+V or Edit > Paste Inside) to obtain the
result shown below:

Gold text with custom bevel

The bevel effect in Fireworks adds shadows and highlights, but they are localized, meaning that the shadowed
or highlighted part may be on the top or the bottom of the text. But by using gradients, you can produce
highlights that look like light is reflecting off many parts of the bevel instead of one area. In fact, when you are
done with this effect, you might realize you haven’t even added a bevel effect, yet it looks like the text has a
beveled edge.

1. Open a new file that is 400 × 300 pixels with a white canvas.

2. Type the word Luxury and use a thick or heavy font. The following settings are the ones I used:

Font: Splash
Point Size: 78
Range Kerning: 5%
Color: black

You can move the image inside the text even after it’s pasted in.
Simply click and drag on the Cloverleaf icon and move the cursor
around until it is positioned where you want it to be.
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3. Place the text near the top of the Canvas and
choose Edit > Clone (CTRL/CMD+SHIFT+D).

4. In the layers panel, select the bottom text
object and turn the visibility off for the top text
object.

5. Now, increase the size of the bottom text to
allow for the bevel. To expand the text path,
you’ll need to convert the text to a path by
choosing the following commands: 

Text > Convert to Paths
(CTRL/CMD+SHIFT+P)
Modify > Ungroup
(CTRL/CMD+SHIFT+G)
Modify > Combine Paths > Union

6. Choose Modify > Alter Path > Inset Path. In the
Inset Path dialog box, select Outside and enter
the value of 4 in the Width box.
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In this step, you converted the text to
paths, but each letter was grouped
together. Because we can’t alter a
grouped path, you ungrouped it and
then combined all the letters into one
shape. Although this object is still a
vector, you can no longer edit the
text as text.

Photoshop Tip: If you are more familiar with Photoshop, you may see
similarities between using Inset Path or Outset Path in Fireworks, and expanding
or contracting a Photoshop selection. However, keep in mind, that would be a
bitmap way. You can do it that way in Fireworks, but using the inset and outset
method makes the most of its vector capabilities. But why not just scale the text?
You can test this easily yourself. Scale the text (Modify > Transform > Scale) and
notice what happens. Scaling does not follow the contours of the shape, whereas
Inset Path and Outset Path do, making them a perfect way to increase or
decrease the size of an object.
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7. Choose a Linear fill and click on the fill color box. Add new color points and colors according to the
placement below:

First color pointer on the left: hex #937500.
Set another color pointer and make it #FFD015.
Alternate the colors, dark, light, dark, light.

8. Adjust the gradient angle so that the
light rays are slanted.

9. Add a new layer and repeat Steps 2
through 7, substituting the word
Edition for Luxury and reducing the
font size to 68 points. When you get to
Step 7, change the direction of the
gradient on the word Edition. 

10. Turn the visibility back on for both of
the black text objects. It doesn’t look
too bad as it is. Notice the highlights
on the bevel. I think they need to be
lightened some though.

11. You could alter the gradient color, but
there’s an easier way that offers more
options: the Levels command. Click on
the plus sign in the Property inspector
to access the Effects list and choose
Adjust Color > Levels. I pulled the two
end sliders in, which changed the Input
values for the shadows (left side) to 27
and the highlights (right side) to 218. 

Once you have the first two colors set,
you can press the ALT/OPT key and drag
a copy over to where you want it.
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This next image shows the bevel after the Levels
command has been applied.

Although the text looks great with just the bevel added,
you can go all out and make the entire text gold by
simply filling the black text with a gold gradient.

12. Select the black text and a Linear fill. Click on the
Edit… button and set the first color to hex
#937500 (the same dark color of the bevel) and
the last color point to #FFD015 (the highlight
color).

13. Adjust the gradient for the first word, Luxury, so
that the dark portion is on top and the highlight
is on the bottom. Reverse for the word Edition –
light on top and dark on the bottom.

14. Try a black canvas color, as shown:
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You can edit any portion of this text except for
changing the font. You could change the font
on the black or top text, but not the one with
the gradient. If you recall, it was combined into
one vector shape. But all the gradients, levels,
and fills are editable. Because this is a vector
object, you can also increase or decrease its size
without degrading the image.



Spectacular Text Effects 08

207

Text with bevel and glow

In this exercise, you add a bevel a bit differently and produce a glow. We are going to vary the results by using
Layer Blend Modes.

1. Open a new document that is 400 x 150 pixels with a black canvas.

2. Type the word Adventure using the following settings:

Font: Ruzicka Freehand RomanSC
Range Kerning: 10%
Point Size: 58

The Ruzicka Freehand RomanSC font is an Adobe font, which costs $25.99; an alternative will work just as well.

3. Fill with a linear gradient of black
and white. Adjust the gradient so
the white is at the top of the letters
and the black is on the bottom.
Name this object text 1.

4. Clone the text (Edit > Clone) and move it below text 1. Name the clone text 2.

5. You will now make the text 2 objects slightly larger by choosing these commands:

Text > Convert to Paths (CTRL/CMD+SHIFT+P)
Modify > Ungroup (CTRL/CMD+SHIFT+G)
Modify > Combine Paths > Union
Modify > Alter Path > Inset Path, choose Outside… and Width of 1.

6. You will also apply a bevel and emboss to
text 2. Click on the plus sign in the Property
inspector to access the Effects list and choose
Bevel And Emboss > Raised Emboss with a
Width of 2 and a Softness of 2. 

7. Select text 1 and clone it (CTRL/CMD+SHIFT+D). Move the clone below text 1 and name it colored.

8. Expand this text as follows:

Text > Convert to Paths (CTRL/CMD+SHIFT+P)
Modify > Ungroup (CTRL/CMD+SHIFT+G)
Modify > Combine Paths > Union
Modify > Alter Path > Inset Path, choose Outside and Width of 3 
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9. Fill with a gradient using these colors
(from left to right) and the positioning as
shown in the image:

#000000 - black
#9966FF - purple
#9933CC - lighter purple
#FF0000 - red
#FFFF00 - yellow
#FF0000 - red
#000000 – black

10. Click on the plus sign in the Property
inspector to access the Effects list,
choose Blur > Gaussian Blur, and enter
4.

11. Use the keyboard down arrow to nudge
the colored text down 5 pixels.

12. Set the Blend Mode of the
colored object to Screen. Also
try Difference. Actually, try all
the different blend modes to
see how they perform and
which one you prefer.

Creating a reflection

In this exercise, you will experiment making a custom perspective shadow for some text. The result will be text
that appears to be standing up. The shadow portion of this text, however, will become a bitmap because of the
selections that are made.

1. Open a new file that is 400 x 300 pixels with a white canvas color.

2. Select the Text tool (T), click on the canvas, and enter Standing Alone. I used Arial with a point size of
38, and a color of black

3. Choose Edit > Duplicate (CTRL/CMD+ALT/OPT+D).
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The Duplicate command places the object a bit below and to the
right of the original object. The Clone command places the object
exactly on top.
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4. Choose Modify > Transform> Flip Vertical. Line up the bottom text below the top text with the bottoms
touching.

5. Select the bottom text, and choose Modify > Transform > Distort. Click and drag on each of the bottom
corners to pull out the bottom edge to add perspective.

6. Now drag in on each of the top corners (the black square) to line up the top and bottom text. Notice
that, as you pull in, the letters shift under the top text. Be careful not to lower the text as you drag or
the text won’t touch. If it moves away, simply click and drag the corner until you get the text to look
something like shown. It’s pretty easy, really. Double-click to complete the transformation.

7. Select the bottom text and choose Modify > Flatten Selection (CTRL/CMD+ALT+SHIFT+Z).

The bottom text is being converted to a bitmap because that’s the only
way I can select just a portion of the text to apply blur and feathering to.
If we were to apply just the blur or just the feathering to the entire object,
it could remain a vector.
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8. Choose Filters > Blur > Gaussian Blur and use a value of 1.5. 

9. Select the Marquee tool (M) and draw a rectangle around the bottom third of the text, the part closest
to you. Choose Select > Feather and enter a value of 10. Choose Filters > Blur > Gaussian Blur and a
value of 2.

10. Draw a Marquee selection two-thirds of the way up and choose Filters > Blur > Gaussian Blur and a
value of 2.

11. Draw a Marquee selection three-quarters of the way up and choose Filters > Blur > Gaussian Blur and a
value of 2. 

The shadow now appears blurrier as it moves away from the base of the text. This type of shadow is more
realistic than just the standard drop shadow. To make the effect stand out even more, I added a rectangle
behind the text filled with a blue gradient.
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In previous versions of Fireworks, the Filters menu was known as the
Xtras menu. Fireworks Xtras are now known as filters.

Optimization Tip: This image would be best suited to export as a JPEG.
Gradients do best as a JPEG, but even if there were no gradient background, JPEG
would still be the better choice because of the blurred edges of the shadow.
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Producing clear small type

Sometimes when you use small type, it can be difficult to read. If that type is being used for navigation purposes,
such as buttons or navigation bars, it becomes even more important that the words are clear and sharp. When
you are faced with the problem of fitting 6 to 10-point text on a button and having it still be readable, try these
tricks:

Turn off the Anti-Alias option. It adds a small amount of blur, and this makes small text more difficult
to read.
Use fonts designed to be read on a monitor. For example, for the PC, use Georgia, Trebuchet, or
Verdana. For the Mac, use Geneva, Monaco, New York, Georgia, Trebuchet, or Verdana.

The figure shows a button with text in 10-point Trebuchet font. The top button
has Smooth Anti-Alias turned on, while the second has no Anti-Alias. It doesn’t
look very good in print or enlarged, but it looks considerably better on screen. Try
it out.

If you find yourself in a position of having to use a font for small type that isn’t suitable for easy viewing, try
this:

1. Type your text at a larger than needed size, perhaps 36 points.

2. Choose Modify > Flatten Selection.

3. Choose Modify > Transform > Numeric Transform > Scale and scale it to about 30 percent or so.

4. If the text looks a little weak, make a clone and place it on top of the original. Reduce the Opacity of
the top clone as needed. Try about 50 percent.

There are custom made small fonts for use on the Web. I have
included a font called Silkscreen which is available to download
from the friends of ED web site. Jason Kottke of www.kottke.org
provided both the PC and the Mac versions.
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Adding copyright and trademark symbols

To add special symbols in Fireworks, you need to know the key combination. To access the Character Map in
Windows, go to Start > All Programs > Accessories > System Tools or run the CHARMAP.EXE file and you will see
the key codes for all the Windows characters. Select the character you want. In the lower-right status bar you’ll
see the key combination.

On a Mac, choose the Apple menu and then click on the Key Caps item. Hold down the OPT key to see
the extended characters; use SHIFT+OPT to see even more.
In Windows, pressing ALT+0169 produces the copyright symbol and pressing ALT+0153 produces the
trademark symbol. On Mac, the copyright symbol is OPT+G, and the trademark symbol is OPT+2.

To add a symbol, select the Text tool, press the ALT/OPT key, and type the key combination.

Summary
In this chapter we have looked at how to use text in Fireworks MX, using the Text tool and the Property
inspector. We’ve also explored the possibilities offered by converting text to paths. We rounded off the chapter
by looking at some of the impressive text effects that we can create using Fireworks. Text is such an important
element of any web site - exciting text carries a great deal of impact, but remember not to go over-the-top and
distract from your message. Now it's up to you to use these techniques to explore your own ideas and make
your own text come alive.
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