Introducing

Animation

What we’ll cover in this chapter:

@ Sprites — what they are and how to use them
@ Keyframes and tweening

@ Animation and your choices to achieve this
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Having invested in some Director real estate in the last chapter, this chapter is going to
show you how to breathe some life into your static world. Director is about far more than
still images so in this chapter, we’re going to start looking at how things move!

Sprites

When you place a cast member onto the stage, you create a sprite. This sprite is not a copy
of the cast member but rather an instance of it. An instance is a new (and distinct)
representation of an original object. For example, if we had a graphic cast member of a
balloon (an example you will see later), you could drag the member from the cast window
onto the stage. The original would still exist in the cast window, but now, on the stage, you
would have a new and distinct version of it: a sprite instance. This instance has its own set
of properties (such as its location on the stage, and its size and transparency), which are
unique from the cast member properties. If we drag the balloon cast member onto the
stage again, a different sprite instance is created. This second sprite instance can have
different sprite properties to the first; it may be located in a different part of the stage,
for example, and will be unique from the original cast member.

This isn’t to say, however, that all links are severed between the original cast member and
the sprite — the umbilical link is kept as one of the sprite’s properties, alongside its other
properties. A consequence of this ‘family’ link is that if a change is made to the original
cast member, this change is filtered down to all its sprite ‘children’. For example, if you
edited the balloon cast member by adding a string to its tail, this string would appear in
both sprite instances. However, if you make a change to an individual sprite, it doesn’t
affect its parent cast member, or its sibling sprites.

You can have up to a thousand sprites in any frame but the more sprites you have in a
single frame, the longer the frame will take to load and run.

Creating sprites
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Open up the vector window with Window > Vector Shape and click on the
Filled Ellipse @ button.

Draw an ellipse in the vector shape window, roughly the same size as in the
screenshot below.

Click on the Gradient Fill button to fill the ellipse with the default
colors, which are probably a light gray to red. Change the destination color (the
color you want to fade to) of the gradient to a dark blue by clicking the color
chip on the right side of the gradient color control, and selecting the color from

the palette that appears.
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Change the Gradient Type on the drop-down menu at the top of your window
from Linear to Radial.
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6.

10.

Select the Pen tool and create four corner points in a row by clicking along the
bottom curve of the outline of the ellipse. If you miss the outline Director will
create a new vector to connect what it thinks is a new line section, so use the
Zoom command to make sure that you get the outline (right-click/Crri-click in
the canvas area and choose Zoom In). You'll see a little pen nib shape like this
appear when you can create a corner point: u

Drag out the two middle points with the arrow to create the end of our balloon,
as shown, and experiment with the gradient Cycles, Spread, X-Offset and Y-
Offset until you get a balloon you’re happy with (I've used Cycles - 1, Spread —
100, X-Offset — 20, Y-offset — 0).

Name your vector shape member balloon in the little window at the top of the
vector shape window (you could also name it in the cast member window).
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You can now close the vector shape window — as with our paint window, this
doesn’t mean that we lose our carefully constructed balloon, so don’t worry. It
would be a good idea to save your Director movie as something like
bal | oon. di r, as we’ll be coming back to it later.

Open your cast window and drag balloon from there to
the stage. You should see something like the screenshot
pictured here. When a visual cast member is placed, or
even selected on the stage, the Sprite Overlay appears,
under the sprite bounding rectangle. The Sprite Overlay
can be turned off and on by choosing View > Sprite
Overlay > Show Info.
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The Sprite Overlay contains some of the sprite’s properties, as well as icons (on the left
side), which open different tabs of the property inspector. Click the different icons to see
which tab of the property inspector opens. The last icon opens the property inspector for
adding behaviors to a sprite, and we’ll be looking at this in the next chapter.

You can change the way the Sprite Overlay is displayed by selecting View > Sprite Overlay
> Settings. This allows you to change the text color, and also, what causes the sprite
properties to display — on Roll Over, Selection or just display all properties with All Sprites.
When the Sprite Overlay is displayed on the stage, the thin line on the right of the overlay
box (indicated by the cursor in the screenshot above) will control its level of transparency.

The Score

The score controls a movie’s content over time — when Director runs a movie it is
interpreting information from the score. The score looks like a spreadsheet, with ‘cells’ in
rows and columns, as pictured.
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Each column of cells is called a frame, and each horizontal row is called a channel. A
frame is a single step, or a moment in time — just like a frame in a traditional film. There
are two types of channel — Effects and Sprite, and these hold ermmmm... effects (timings,
palettes, sound and so on), and sprites (just like our little balloon). We'll be looking at
effects in later chapters, and concentrating on sprites in this one.

Sprite channels are where all the visible media in a movie is placed. Each channel can be
thought of as a layer in your presentation. If your layers overlap, then the highest layer (in
number) in the list will always appear on top. So a sprite in channel two will appear above
a sprite in channel one.
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1.

2.

The Playback Head is the red rectangle at the top with a red line running vertically
through all the channels. It tells you exactly where you are in a movie, and what frames
are displayed on the stage at that point. You can drag the playback head through frames
with the mouse to get a rough idea of what your movie will look like at different frames.

Let’s go and have a look at the Score for our balloon.

Select Window > Score. You should see something like the previous screenshot.

The sprite toolbar is where all the unique sprite properties we’ve just talked about
can be seen. This may be missing from the top of your score window — you can
see it in the screenshot before as showing the thumbnail of our balloon, and other
details alongside. Choose View > Sprite Toolbar to show it if it’s not there.

The score can be contracted to hide the effects channels. We’re going to be
concentrating on the sprite channels, so press the Hide/Show Effects Channels
icon [4 to hide it for the moment. It’s not easy to find, but on the far right-hand
side above the scrollbar is a button that allows you to zoom in or out of your
Score, and it’s just above this.
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You should now be able to see your balloon stretching over 28 frames, as pictured.
Select the balloon sprite by clicking on it anywhere between its start and end
frame. Press the DELETE or BAcksPACE key on the keyboard to delete the sprite.

Select File > Preferences > Sprite and in the sprite preferences box that appears,
type 1 next to Span Duration. Then click the OK button. We have just requested
that our sprites should only be one frame long, so the next time we place a
sprite in the score this is how long it will be. We can then decide for ourselves
how many frames we want it to extend to.
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6. Select the balloon cast member, and drag it directly into frame 1 in channel 1
of the score. Just as when we dragged the balloon onto the stage, and it
appeared automatically in the score, dragging it onto the score will have exactly
the same effect as dragging it onto the stage. The only difference from last time
is that if you now look at the stage, you will see that your balloon appears in the
exact center — images dragged into the score are always centered on the stage.

7. Now we can extend our balloon to the number of frames that we want. Select
the frame 1 balloon sprite in channel 1 of the score, press the SHIFT key, and
while holding it down click frame 40 in channel 1. On the PC a rectangular
selection frame will momentarily flash in the score, on the Mac the frames turn
black, indicating the frame range has been selected. Select Modify > Extend
Sprite and the sprite should now extend over 40 frames.

8. There’s another way to extend sprites — select the end frame of the sprite and
drag the sprite back to frame 1. In the sprite toolbar, on the top line, just next
to the percentage value, you’ll see a Start Frame and an End Frame box. Change
the End Frame property to 40.
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9. What if we want to delete a frame? While the sprite is extended over 40 frames,
click on frame 20 and select Insert > Remove Frame. The frame will disappear,
and all the frames after it will move back one frame. To delete several
consecutive frames, you have to select the first frame by clicking in the row
between the sprite and effects channels (where the playback head appears) and
holding SHIFT down before clicking on the last frame. Then choose Edit > Clear
Frames, or press the DELETE or BACKSPACE key.
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So, we’ve moved our balloon about a lot, but this is getting a little boring, isn’t
it? Well, now is the time to put our newfound score knowledge into practice
and create our very first Director animation!
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Strobing balloon

Make your balloon sprite 40 frames long once again. Select it and choose Edit
> Edit Sprite Frames. Instead of being one long segment, the sprite will now
appear as a number of rectangles with a line running from frame 1 to 40 (except
for where the sprite name appears). This mode of viewing sprites is called Open
Sprites, and allows you to edit each frame separately.

Just to be safe, save your efforts as bal | oon. dir.

Click on frame 5, and while holding the SHiFT key, click frame 8 to select the
range of 4 frames. Press your DELETE key to remove the frames between 5 and
8. Two separate sprites are now created in the single channel.
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Using the same process, delete frames, alternating 4 frames clear, 4 frames
occupied, as shown below.

b
Membes i I I-!
ir.'/hul:! i) Bl Bl Eibialr

Once this is done, our animation is ready to play — that was easy! To play our
animation through in Director, we can use the controls offered to us in the
control panel, so select Window > Control Panel. Click on the play icon, and
your first Director animation will play on the stage. Well done — it’s only a
flashing effect, but everything has to start somewhere.

The control panel actually allows you to do far more than the obvious play, rewind, pause,
step forward and step backwards functions. The volume button %2 allows you to alter
the movie volume when editing - it won’t affect your final movie. Above the play button,
you'll see the frame number it’s going to play from, which you can change by entering a
new number and hitting Enter, while the button in the bottom_right-hand corner allows
you to select a range of frames to play. The button above this "= | (fairly obviously) allows
you to choose whether to loop your movie or not. Finally, the top fps (frames per second)
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box allows you to set how fast your movie should run, and the bottom box tells you the
speed your computer is actually achieving — if it’s slower than the top, then you’re pushing
your movie too hard and need to consider decreasing it or optimizing your movie. More
on all this later, but feel free to try it all out on your balloon — enjoy!

Keyframes and tweening

Director makes animation creation easy through the use of keyframes and tweening.
Tweening is a shortened version of ‘in-betweening’. You specify the start and end sprite
property (such as position on the stage) and Director will work out all the in-between
frames for you. Director tweens the change of properties between keyframes. A
keyframe is a point in an animation sequence from which properties of other frames,
before and after the keyframe, are extrapolated.

1. Openball oon. dir from step 2 in the
last exercise. In the score, select the
sprite and delete it. Select the balloon
in the cast and drag it onto the left side
of the stage.
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2. In the score, extend the sprite to our
standard forty frames, and select the
last frame. On the stage, press and
hold the SHiFT key, and drag the
balloon to the right side. If you play
around with moving the balloon while
holding the SHiFT key, you'll see that it
restricts movement to left, right, up,
or down from the starting point.

3. When you drag the balloon from its marked center point, a horizontal line
appears, linked by two circles at each end. Each circle represents a keyframe.
Hold down SHIFT and drag the balloon from its center point to the right of the

& »
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stage. If you look at the sprite in the score, you'll notice the end frame is now
a keyframe too — as shown by the circle, rather than the rectangle shape it was
before. Changing the sprite property of an end frame automatically converts it
to a keyframe.

Rewind and play your movie, or drag the playhead back to frame one in the
Score. The line you see on the stage represents the animation path between
keyframes.

Click on frame 10 of the sprite in channel 1. Select Insert > Keyframe and a circle
will appear at frame 10. Insert further keyframes at frames 20 and 30.
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On the stage, double-click the circle | ——————

representing keyframe 10 (the second
circle from the left on the path line).
This will activate that frame. Click and
drag the balloon up slightly. Do the
same for keyframe 30, creating a path
similar to that shown here.

Rewind and play the movie.

The animation we’ve created follows a curved path, with the curvature set by
Director’s tween default settings. Let’s change these settings. Select the sprite
sequence in the score, and go to Modify > Sprite > Tweening. The Sprite Tweening
box will appear. Click on the Curvature slider in the middle of the box and drag it
to the Linear end of the bar. This will makes the sprite move in a straight line
between the keyframe locations. Moving it to the other end of the bar will make
the path follow a more curved line, as you'll see in the graphical representation on
the left if you drag the slider over that way. Press OK when you’re done.
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Rewind and play the movie. The path is now less curved than before, and the
animation follows a more zig-zag animation.

The sprite tweening dialog box also allows you to control the way Director
tweens sprite properties. As default, Director will tween all sprite properties
that are modified at keyframes, but you can tell Director to tween some
properties and not others, by changing the settings. The Continuous at
Endpoints option will smooth a closed path at the beginning and end points of
the animated path. A closed path is when the first keyframe and last keyframe
have the same x and y location:

The path on the left does not have Continuous at Endpoints enabled, but the
path on the right does. Note that the pointy section in the image on the left is
the where the endpoints meet.

Let’s play with this some more. Use Insert > Remove Keyframes to remove the
keyframes at frames 10, 20 and 30, select the sprite and choose Modify > Sprite
> Tweening. At the bottom of the window, you'll see two slider bars. Ease-In
defines the ‘speed’ percentage of the sprite when the sprite speeds up, and Ease-
Out defines the ‘speed’ percentage of the sprite when the sprite slows down.
Change the Ease-Out percentage to 50, and then rewind and play the movie as
before. The animation will start off quickly and then slow down - if you look at
the dots on the animation path you will notice they become denser towards the
right-hand end of the path. Try modifying the Ease-In settings in the same way.
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1.

11. The Tweening dialog box also allows you to select Sharp Changes (the default)
or Smooth Changes. Sharp Changes will move the sprite between keyframe
locations without adjusting the speed, which can make changes look abrupt,
while Smooth Changes will adjust the sprite’s speed gradually as it moves
between keyframes, making the animation appear smoother. Try selecting

Smooth Changes and replaying your movie.

So we’ve seen how to use keyframes to set up tweens, and how to alter the tweens. We're
now going to move up a notch and see how we can alter our original sprite in order to
create even more exciting tweening effects. Specifically, we’re going to look at size,
rotation, transparency and color.

the Sprite tab is selected. Click on the first

Click on the property inspector, and make sure [T !j e
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keyframe, and click on the Scale button in the |_

bottom-right corner of the inspector. This will
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In the scale sprite box, change the Scale to 250%. Change the Scale of keyframe
40 to 50% (You can also adjust the size of a sprite by clicking it on stage and

stretching it).

Scale Sprite
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It’s really important that you have the correct keyframe selected before altering
the size — if you don’t, you’ll just alter the size of the whole sprite sequence each
time. It’s also important to know, if you want to go back and change any of the
values in the scale sprite box after you’'ve applied them, that Director resets the
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percentage back to 100% every time a scale value is applied. So you will always
have to scale up or down from 100%. For example, if you had scaled to 250%
and then went back and wanted to scale it 260%, you would enter 110% in the
scale box.

Rewind and play the movie. You have now animated the size of a sprite!

Time for some rotation. In the sprite toolbar, change the sprite rotation for the
first keyframe to O, and for keyframe 40 to 360, as shown below. Rewind and
play the movie, and you’ll see your balloon spin.
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That was easy, wasn’t it? So let’s carry on and try transparency and color
together. Click on keyframe 40, and then, in the Blend % box in the Sprite
Toolbar, just above the X and Y values, type in 0 and press ENTER.
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Rewind and play the movie and the balloon will fade as it animates — cool!

Time for the color. Double-click the balloon on the stage to open the vector
shape window and change the destination color of the gradient to yellow. Then
change the Blend of keyframe 40 to 100%.

Return to the sprite toolbar and change the foreground color for keyframe 1
to yellow and keyframe 40 to dark blue. Rewind and play the movie and then
save it.

The balloon now animates from yellow to green to blue. This animation
technique works well for shapes, and vector shapes with light colors. It doesn’t
work for text. While it does work with bitmap images, the results aren’t as
effective (except for 1-bit images). Try it and see for yourself.
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Up until now, we’ve been dealing with just one sprite — our balloon. You
will quite often have more than one sprite in a particular frame, and
when you do, modifying one individual sprite can become tricky. The
answer to this is to lock the sprites you don’t want to change by
selecting them and clicking on the Lock icon in the Sprite Toolbar | i |.
Try this with your balloon and you’ll see that the sprite representation
in the score will appear grayed-out with a Lock icon next to it, and you
won’t be able to move it around the stage. Unlock your balloon by
clicking again on the Lock icon.

Changing the speed of movies

The speed of movies is known as the Tempo in Director, and is measured
in frames per second. If a movie plays at 15 frames per second, then each
frame would represent 1/15th of a second. Since a movie can play at
different rates through a single presentation, the time that each frame
lasts may vary.

The tempo can be set in the tempo channel (discussed in chapter 5),
through Lingo (discussed in chapter 10) or through the control panel. To
change the tempo in the control panel, use the up and down arrows

next to the tempo setting M| 15 2|. The default tempo for any
new movie you create is 30fps. The control panel is useful to adjust the
tempo during authoring. To specify an exact frame rate for your final
movie, you’ll need to set a tempo through the tempo channel or Lingo.
Setting the tempo in these ways will override any settings you enter in
the control panel.

Your fps setting is never 100% accurate when you export, whatever you do.
For example, Director can set the maximum frame rate for a movie, but if
the CPU and RAM is low, then that high frame rate will not be maintained.

Further animation techniques

We have now looked at creating animation by adding keyframes and allowing Director to
tween the properties for us. Director offers you two further ways of creating animation —
Step Recording and Real-Time Recording. These are not so much alternatives as
methods that can be used in different circumstances. Keyframes and tweens will remain
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the bread and butter of your Director work, but step recording can be used for extra fine
tweaking, and real-time recording can be used for the opposite — to quickly create an
animation that will be tweaked and fine-tuned later.

Animating with real-time recording

Real-time recording allows you to create your animation by dragging a sprite around the
stage, and letting Director record the path. Recording begins when you first click on the
sprite and stops when you release the mouse button. This technique can be really useful
for setting a rough path that you can tweak with keyframes and so on later.

1. Open the movie you created in the last exercise, and delete the sprite. Drag
your balloon cast member into the bottom left corner of the stage, as before.

2. Select the sprite, and choose Control |[EEEEE———————— ul
> Real-Time Recording. A red circle
will appear at the beginning of the
channel, and on the stage a red
striped box will bound the sprite.

3. Drag the sprite around the stage to record a path for the sprite, and release the
mouse button to stop recording when you’re ready. If you've got looping
selected, you'll get an instant replay of your moves, otherwise rewind and play
the movie ... ta-da!

Animating with Step Recording

Step recording is a process whereby you create animation by working on each consecutive
frame individually. In the early days of animation, this is how cartoons were created —
movement was simulated by building up a number of drawings which, when seen quickly
over time, appeared as animation. In Director, it’s not as much hard work as it was then,
but it’s a little more time-consuming than a normal tween. In return, though, you gain
more precise control over your animation.
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1.

1.

Open your balloon movie and delete the sprite animation, so that the score is
empty. Place the balloon cast member on the stage towards the bottom left
corner and stretch the sprite over 40 frames.

Select the sprite and click the rewind button on the control panel so that the
playback head moves to frame 1, and then select Control > Step Recording. A
red (step recording) indicator will appear at the beginning of the channel, in
the score.
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Click on the Step Forward button L% in the control panel, and then click and
drag the sprite on the stage. Repeat this for a series of frames, creating a path
of your choice. You will notice that every time you click the Step Forward
button, a keyframe is created in your score.
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Rewind and play the movie. As soon as you move the animation in any way other
than Step Forward (using the rewind, play, or back buttons for example),
recording will stop. If you continue step recording beyond the end frame of the
sprite, Director will insert new keyframes in the subsequent frames. (To step
record over a specific range of frames, you can select the frame range and then
click on the Selected Frames Only button on the control panel.)

Space to Time

Step recording gives precise control over animation, but doesn’t allow you to see the
preceding and subsequent frames while you modify each keyframe. To do this, we can use
the space to time command. Using this command we can place each sprite on the Stage,
in its own channel, and arrange them in relation to each other. When we’re happy, we can
then automatically send them all into one channel to create our animation. Doing an
exercise based on this will make things clearer — so here we go!

Create a new movie with a stage size of 640 x 480, and make a Paint rectangle
filled with a solid color.
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2. Click and drag the rectangle to the stage a few times, creating a pattern similar
to the one shown in the screenshot.
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You should see that the sprites will follow a
consecutive order in the score, reflecting the
order they were dragged onto the stage, as
shown here:
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3.

1.

Select all the sprites by choosing Edit > Select All, or using the SHIFT key, and
clicking the first and last sprite. If your sprites are more than one frame long,
then change the End Frame property to 1.

Choose Modify > Space to Time and the Space to Time dialog box appears:

Space o Time x
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Set the Separation of frames to 1 and press the OK button, before rewinding
and playing the movie. You'll see that not only have all your sprites been
miraculously placed into just one channel, but that the path and speed reflects
the way you placed the sprites in the single frame — the closer they were, the
slower that segment of the animation appears.

Cast to Time

While space to time sends single framed sprites in different channels to a single channel,
cast to time sends multiple cast members to a single sprite. The cast to time command is
useful for animation that is created through a series of changing images. We’re going to
use the paint window to create our images in the following example, but you could just
as well import the images in from a third-party program, such as Photoshop.

Create a new movie with a stage size of 640 x 480, with a white background
color. Open the paint window.

Change the foreground color to a light blue and use the Filled rectangle tool to
draw a rectangle in the middle of the canvas area. The proportions do not
matter at this time since we will be changing them.

Click and hold down the Marquee button |_i. In the pop-up menu that appears,
make sure Shrink is selected, and then draw a selection rectangle around the
rectangle. The selection shrinks to the edge of the graphic.

In the distort toolbar at the top of your paint window, click the Warp
button [_5 and move each corner node to create a diamond shape like the one
pictured in the following screenshot.
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5. Change the foreground color to a dark brown and use the Line tool to draw a
horizontal and a vertical line.
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6. Use the Marquee as in step 3 to select the entire graphic.

7. Use the Warp button again to distort the kite as shown.
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8.

10.

11.

12.

Choose Xtras > Auto Distort and in [T =
the auto distort box that appears

type 10 in the number of cast —= ""'""‘l
members to generate, then click Govmn [T HowCottomis _Corce |
Begin. = 3

Ten new cast members are generated. Your cast window will now display ten
extra images of the kite, each looking slightly different. The Auto Distort Xtra
comes with Director 8.5, but you can find out more about other Xtras by taking
a look at the Xtras appendix.

Select all 11 cast members in the cast
by clicking on the first and then
pressing SHIFT while clicking on the last
member. Click frame 1 in channel 1 of
the score and choose Modify > Cast to
Time. A single sprite will be created.
You can now rewind and play the
movie. If you have looping on, you may
notice you have a short animation
which repeats itself. As a little
experiment, try adjusting the tempo in
the control panel from 1 fps to 99 fps,
as described earlier, and observe the
change.
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To finish off, we’re just going to have a little bit of a play with our kite.

Select the sprite in channel 1 and choose Modify >
Transform > Rotate Left and rewind and play the | /i q\z I_gnm
movie. We rotated the sprite by 90 degrees, so it

looks more like a sail now. If you look at the JH.;q.au._-.l;-]":’,ﬁﬂglE
Rotation Angle property in the property inspector
or sprite toolbar, you will see it has been changed
to -90.

Select the sprite in channel 1 and choose Modify >
Transform > Mirror Vertical. Rewind and play the movie =

again. This will change the Skew Angle to 180, creating 150,00
a vertical mirror of the animation we had before.

Skew Angle

Select the sprite in channel 1 and choose Modify > Transform > Reset All to
remove our sprite transform modifications. Copy and paste the sprite so you
end up with two consecutive sprite sequences in channel 1. Copy your sprite
sequence and then use Edit > Paste Special > Relative to align the start frame
of the pasted sprite to the end frame of the preceding sprite.
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13. Select the second sprite sequence and choose Modify > Reverse Sequence
before rewinding and playing the movie. The animation will now move forward
and then back to where it started.

14. As two separate sprites, we have less control over this animation, so let’s join
them into a single sprite. Select the two sprites, choose Modify > Join Sprite and
the two sprites will merge into one. Joining sprites merges the sprite information
of all the joined sprites into one, and you can only join sprites in the same
channel. To do the opposite, you can use Modify > Split Sprite, which will split
a sprite into two at the frame where it is activated. We can now easily animate
our single sprite as we did with our balloon earlier — let your creativity run wild
and have a play with your kite before you move on to do even more in the next
chapter. When you have finished, save your work as kite.dir.

Summary

Sit back, take a deep breath and take a look at what you’ve achieved in this chapter.
Balloons, kites and the like might not seem that impressive, but think of the number of
doors that this has opened up for your Director presentations. You can now effortlessly
animate bitmaps and vectors and manipulate those animations as you please.

Animation is at the heart of any presentation that begins to truly harness the power of
Director. Most of what we’ll be doing in the rest of the book will be built on the
foundations we’ve laid in this chapter. Hold on tight — the journey has only just begun!

In this chapter, we learned about:
@ Sprites, and how they are shown and organized in the score

@ Keyframes, and how they’re used to vary sprite properties over time, using
tweens, step recording for extra control, or real-time recording to create a
rough path

@ Sprite animation that can be developed in a series of single frames in separate
casts and then merged into one channel over a range of frames with the space
to time command. Changing cast members can be automatically made into a
single sprite with the cast to time command.







